Comandos de Linux

4 formas de deshabilitar/bloquear ciertas actualizaciones de paquetes usando el comando yum

4 formas de deshabilitar/bloquear ciertas actualizaciones de paquetes usando el comando yum

Gerente de empaquetación es software que permite a un usuario en caso de instalación de un nuevo software, gradación de aumento del sistema o actualización de cualquier software específico y este tipo de cosas. En el caso de los sistemas basados ​​en Linux en los que un software tiene muchas dependencias que deben estar presentes en el sistema para una instalación completa de ese software, el software como el administrador de paquetes se convierte en una herramienta muy necesaria en cada sistema.

Cada distribución de Linux se envía con su administrador de paquetes predeterminado para funcionalidades mencionadas anteriormente, pero de todas estas más encontradas son: beque en Rhel y Fedora sistemas (donde se reemplaza actualmente con DNF de Fedora 22+ en adelante) y apto de Debian.

Si estas buscando APTO herramienta para bloquear o deshabilitar ciertas actualizaciones específicas de paquetes, entonces debe leer este artículo.

Desactivar/bloquear o la actualización del paquete Certian de la lista negra con APT

DNF o Danificado Yum se está reemplazando beque en Fedora sistemas que es otro en nuestra lista. Si se explora correctamente, estos administradores de paquetes se pueden usar para seguir funcionales:

  1. Instalación de un nuevo software desde el repositorio.
  2. Resuelva las dependencias del software instalando esas dependencias antes de instalar el software.
  3. Mantener una base de datos de dependencias de cada software.
  4. Versión de degradación de cualquier software existente.
  5. Actualización de la versión del núcleo.
  6. Listado de paquetes disponibles para la instalación.

Ya hemos cubierto artículos detallados por separado en cada administrador de paquetes individuales con ejemplos prácticos, debe leerlos para controlar y administrar la gestión de paquetes en sus respectivas distribuciones de Linux.

Leer también:

  1. Dominar el comando yum con estos 20 ejemplos prácticos
  2. 27 comandos DNF para administrar paquetes en Fedora 22+ Versiones
  3. Aprenda 25 comandos APT para administrar los paquetes de Ubuntu

En el artículo, veremos cómo bloquear/deshabilitar ciertas actualizaciones de paquetes Uso de Yum Package Manager en sistemas RHEL/CentOS y Fedora (aplicable hasta Fedora 21, Más tarde, la nueva versión de Fedora se envía con DNF como Administrador de paquetes predeterminado).

Desactivar/bloquear las actualizaciones de paquetes con YUM

Actualizador de perros amarillos, modificado (beque) es la herramienta de gestión de paquetes en distribuciones basadas en Redhat, como Centos y Fedora. A continuación se analizan varias estrategias utilizadas para bloquear/deshabilitar las actualizaciones de paquetes usando YUM:

1. Deshabilitar permanentemente el paquete para la instalación o actualización

1. Abra y edite el beque.confusión archivo, que se encuentra en /etc/yum.confusión o en /etc/yum/yum.confusión.

Parece a continuación:

[Main] Cachedir =/Var/Cache/Yum/$ Basearch/$ Releasever KeepCache = 0 DebugLevel = 2 logFile =/var/log/yum.LOG EXIGACH = 1 obsoletes = 1 gpgcheck = 1 complementos = 1 instalación_limit = 5 bugtracker_url = http: // bugs.cento.org/set_project.php?Project_id = 23 & ref = http: // bugs.cento.org/bug_report_page.php?categoría = yum distroverpkg = centos-libe… 

Aquí, para excluir cierto paquete de la instalación o la graduación de aumento, solo necesita agregar la variable de exclusión junto con el nombre del paquete que desea excluir. Por ejemplo, si quiero excluir todo el python-3 paquetes de actualizarse, entonces solo agregaré la siguiente línea a beque.confusión:

excluir = Python-3* 

Para que más de un paquete excluyan solo separar sus nombres por espacio.

excluir = httpd php 
[Main] Cachedir =/Var/Cache/Yum/$ Basearch/$ Releasever KeepCache = 0 DebugLevel = 2 logFile =/var/log/yum.LOG EXIGACH = 1 obsoletes = 1 gpgcheck = 1 complementos = 1 instalación_limit = 5 bugtracker_url = http: // bugs.cento.org/set_project.php?Project_id = 23 & ref = http: // bugs.cento.org/bug_report_page.php?categoría = yum distroverpkg = liberación de centos excluir = Python-3* [Excluir un solo paquete] excluir = httpd php [Excluir múltiples paquetes]… 

Nota: incluir estos paquetes, ignorar las entradas en beque.confusión, usar "-desactivar EXCLUUD"Y establecerlo en Todos | Principal | Repoide, dónde 'principal' ¿Son los ingresados ​​en beque.confusión y 'Reproid' son aquellos cuya exclusión se especifica en repositar.d directorio, como se explica más adelante en.

Ahora intentemos instalar o actualizar los paquetes especificados y ver que el comando YUM los deshabilitará de la instalación o actualización.

# yum install httpd php Plugins cargados: Fastestmirror, Langpacks, Velocidades de espejo de carga de VersionLock desde el archivo host en caché * Base: Mirror.NBRC.C.A.En * Epel: Mirror.WANXP.ID * extras: espejo.NBRC.C.A.En * actualizaciones: espejo.NBRC.C.A.en Nada que hacer 
# yum actualización httpd php Plugins cargados: Fastestmirror, Langpacks, Velocidades de espejo de carga de VersionLock desde el archivo host en caché * Base: Mirror.NBRC.C.A.En * Epel: Mirror.WANXP.ID * extras: espejo.NBRC.C.A.En * actualizaciones: espejo.NBRC.C.A.en No hay paquetes marcados para la actualización 

2. Deshabilitar temporalmente el paquete para la instalación o actualización

2. Arriba era una solución permanente para excluir un paquete como a menos que se edite el archivo, ese paquete no se actualizará. Aquí hay una solución temporal para esto también. Justo en el momento en que vaya a cualquier actualización, use -X Cambie en el comando yum para excluir el paquete que no desea actualizar, como:

# actualización de yum -x python -3 

El comando anterior actualizará todos los paquetes cuyas actualizaciones están disponibles, excluyendo python-3 en tu sistema.

Aquí, para excluir múltiples paquetes, usar -X varias veces o separar los nombres de paquetes con ',' en un solo interruptor.

# yum -x httpd -x php actualización o # yum -x httpd, actualización de PHP 

3. Usando --excluir El cambio funciona igual que -X, Solo necesito reemplazar -X con -excluir y pasar ',' Lista separada de nombres de paquetes.

# yum --exclude httpd, php 

3. Deshabilitar actualizaciones de paquetes con repositorio

4. Para cualquier paquete instalado desde cualquier fuente externa mediante la adición de un repositorio, hay otra forma de detener su graduación en el futuro. Esto se puede hacer editando su .repositorio archivo que se crea en /etc/yum/repos.d/ o /etc/yum.repositar.d directorio.

Agregue la opción Excluir con el nombre del paquete en el repositorio. Me gusta: para excluir cualquier paquete, digamos vino de Repo Epel, Agregue la siguiente línea en epel.repositorio archivo:

[Epel] Nombre = paquetes adicionales para Enterprise Linux 7 - $ Basearch #baseUrl = http: // Descargar.federaproject.org/pub/epel/7/$ basearch espeurrorList = https: // espejos.federaproject.org/metalink?Repo = Epel-7 & Arch = $ Basearch WaaloverMethod = Priority habilitado = 1 gpgCheck = 1 gpgkey = file: /// etc/pki/rpm-gpg/rpm-gpg-keyke-epel-7 excluir = vino 

Ahora intente actualizar el vino Paquete, obtendrá un error como se muestra a continuación:

# vino de actualización de Yum Complementos cargados: FastestMirror, Langpacks, VersionLock Epel/X86_64/Metalink | 5.6 KB 00:00 Speeds de espejo de carga desde el archivo host en caché * Base: Mirror.NBRC.C.A.En * Epel: Mirror.WANXP.ID * extras: espejo.NBRC.C.A.En * actualizaciones: espejo.NBRC.C.A.En ningún partido para el argumento: vino No hay vino de paquete disponible. No hay paquetes marcados para la actualización 

4. Deshabilitar la actualización del paquete usando la opción VersionLock

5. Otra forma en Yum para enmascarar la versión de cualquier paquete, por lo que no está disponible para la graduación versiones de la versión opción de yum, pero para hacer esto, debes yum-plugin-versionlock Paquete instalado en el sistema.

# yum -y instalar yum -versionlock 

Por ejemplo, para bloquear la versión del paquete, digamos httpd a 2.4.6 Solo, simplemente escriba el siguiente comando como root.

# Yum VersionLock Agregar httpd 
Salida de muestra
Complementos cargados: FastestMirror, Langpacks, VersionLock Agregar VersionLock en: 0:httpd-2.4.6-40.El7.cento VersionLock agregado: 1 

Para ver los paquetes bloqueados, use el siguiente comando enumerará los paquetes que se han bloqueado la versión.

# Yum VersionLock List Httpd 
Salida de muestra
Complementos cargados: fastestmirror, langpacks, versionlock 0:httpd-2.4.6-40.El7.cento.* Lista de Bolsas de Versiones Hecho 

Conclusión

Estos son algunos consejos que lo ayudarán a deshabilitar/bloquear las actualizaciones de paquetes con Yum Package Manager. Si tienes algún otro truco para hacer las mismas cosas, puedes comentarlos con nosotros.

Restablecimiento del dispositivo de banda ancha móvil Vodafone USB con USB_ModesWitch
La primera vez que utilicé mi dispositivo de banda ancha móvil Vodafone USB en mi sistema Fedora Linux, funcionó perfectamente . Sin embargo, después ...
El NTOP 10TOP 10 ingresando una interfaz de comando Redboot Boot Loader
Si posee un almacenamiento NAS THECUS 2100 y debe recuperarse de algún accidente de software, tiene dos opciones. Uno es usar un conector serie USB o....
Instalación de Sikuli en Ubuntu Lucid Lynx Linux
El software Sikuli ayuda a un usuario a automatizar muchas de las tareas de rutina de GUI. Core usa Java Runtime Environment 6 y OpenCV (Visión de la ...